pgsql: Fix SSPI login when multiple roundtrips are required

Started by Magnus Haganderabout 15 years ago1 messagescomitters
Jump to latest
#1Magnus Hagander
magnus@hagander.net

Fix SSPI login when multiple roundtrips are required

This fixes SSPI login failures showing "The function
requested is not supported", often showing up when connecting
to localhost. The reason was not properly updating the SSPI
handle when multiple roundtrips were required to complete the
authentication sequence.

Report and analysis by Ahmed Shinwari, patch by Magnus Hagander

Branch
------
master

Details
-------
http://git.postgresql.org/pg/commitdiff/0886dde5f83611d1d84a29cb3c4549bf6588668e

Modified Files
--------------
src/backend/libpq/auth.c | 10 ++++++++--
1 files changed, 8 insertions(+), 2 deletions(-)